Blog

Some Site Layout, AdSense Tweaks

I made some changes to the layout/content of the sidebar. I’m trying out Google’s Link Units, over on the right. It uses the AdSense algorithm to pick out some key words that match the page, and when you click on the work, you see some ads targeted at that keyword. The ads you see are guaranteed to be what you’re looking for, since you clicked on the keyword. Pretty clever, I think.

The other change was to insert an ad after each post. I hope that this will make the ad algorithm target what’s in each post, rather than try to figure out what ads it should display for all of the posts on the front page, which usually cover a broad range of specific topics (all geeky, of course).

The one thing I’ve always liked about AdSense ads is that they’re usually so relevant that they’re like extra related content, rather than ads. At the same time, I’m not trying to make a ton of money with this site – just enough to pay for hosting, and maybe pick up a new gadget every once in a while, to keep the geekiness flowing.

That being said, I don’t want to cross the line into being one of those “ad-infested” sites, so please feel free to let me know what you think about the tweaks I’ve made. Hopefully they’re not too annoying. If they’re driving people away from the site, I’ll dump them, but I’m hoping that you don’t mind, and that the ads are relevant enough that you’ll even click on them when you come to visit. :-)

Standard

2 thoughts on “Some Site Layout, AdSense Tweaks

  1. Hey Josh! Love your podcast! I have no trouble with Ads or Adsense, and your site isn’t too cluttered. As a matter of fact, why not put them where your feed would pick them up so I can click on them from my feed reader? Also, if I click on a post from my fee reader, there is no link from the post page to your main blog page. HTH

  2. I’ve actually applied to participate in Google’s beta of AdSense for Feeds – I know most people get TinyScreenfuls via RSS – and I’m waiting to hear back from them.

    As far as there being no link back to the main page, I think this is an artifact of the new header graphic I put up. I’ll look into a way to fix that, because it annoys me, too.

    Thanks for the feedback!

Comments are closed.